Lunar: Silver Star Story doesn't work in K1v3

Software title information and feedback tested by customers
Forum rules
Before posting, make sure you have tried all the EXTDSP settings available found in the 'Options' in the Menu System! Also be sure to check JIRA if your game is currently not working and is already being worked on.
User avatar
Matt
Cybdyn Systems - Admin
Cybdyn Systems - Admin
Posts: 2455
Joined: December 31st, 2012, 5:37 pm
I am a: Systems Designer
PlayStation Model: H2000/5502
Location: Australia
Contact:

Re: Lunar: Silver Star Story doesn't work in K1v3

Post by Matt » August 30th, 2019, 12:10 pm

Okay. Does it work with it off?

SavitarSvit
Active at Cybdyn Systems
Active at Cybdyn Systems
Posts: 52
Joined: May 14th, 2017, 3:09 am

Re: Lunar: Silver Star Story doesn't work in K1v3

Post by SavitarSvit » August 30th, 2019, 2:37 pm

Lunar (U) work fine on a last firmware. Midboot on.

mario64
Member
Member
Posts: 18
Joined: August 4th, 2019, 9:23 am

Re: Lunar: Silver Star Story doesn't work in K1v3

Post by mario64 » August 30th, 2019, 11:01 pm

SavitarSvit wrote:
August 30th, 2019, 2:37 pm
Lunar (U) work fine on a last firmware. Midboot on.
Not for me it doesn't. It consistently hangs. Make sure you're talking SSS not Blue. To test Matt simply launch the game and let it run its demo loop for, say 30-60 minutes. It will hang regardless if using Midboot or not - even with K1V2

fernan1234
Lives in the Cybdyn Systems Server
Lives in the Cybdyn Systems Server
Posts: 179
Joined: June 4th, 2018, 8:23 am

Re: Lunar: Silver Star Story doesn't work in K1v3

Post by fernan1234 » August 30th, 2019, 11:12 pm

So did this game (Lunar SSS) work issue-free with K1V2 in the previous firmware, but not in the latest one? Matt didn't mention that any changes were made to the older K1V1-3 modes.

User avatar
Matt
Cybdyn Systems - Admin
Cybdyn Systems - Admin
Posts: 2455
Joined: December 31st, 2012, 5:37 pm
I am a: Systems Designer
PlayStation Model: H2000/5502
Location: Australia
Contact:

Re: Lunar: Silver Star Story doesn't work in K1v3

Post by Matt » August 31st, 2019, 11:01 am

We'll check it out.

SavitarSvit
Active at Cybdyn Systems
Active at Cybdyn Systems
Posts: 52
Joined: May 14th, 2017, 3:09 am

Re: Lunar: Silver Star Story doesn't work in K1v3

Post by SavitarSvit » August 31st, 2019, 5:17 pm

fernan1234 wrote:
August 30th, 2019, 11:12 pm
So did this game (Lunar SSS) work issue-free with K1V2 in the previous firmware, but not in the latest one? Matt didn't mention that any changes were made to the older K1V1-3 modes.
Another person needs to check the game.
I checked the game on K1V2, the latest firmware.
I started the game from the beginning and watched 3 cutscenes. Then I started the game from the last save and also ran around the game. I didn’t see any problems.

User avatar
Matt
Cybdyn Systems - Admin
Cybdyn Systems - Admin
Posts: 2455
Joined: December 31st, 2012, 5:37 pm
I am a: Systems Designer
PlayStation Model: H2000/5502
Location: Australia
Contact:

Re: Lunar: Silver Star Story doesn't work in K1v3

Post by Matt » August 31st, 2019, 5:59 pm

Working fine for me. Using "Midboot". Watched 4 cutscenes. Check your game MD5 matches redump.

mario64
Member
Member
Posts: 18
Joined: August 4th, 2019, 9:23 am

Re: Lunar: Silver Star Story doesn't work in K1v3

Post by mario64 » September 1st, 2019, 9:23 am

Matt wrote:
August 31st, 2019, 5:59 pm
Working fine for me. Using "Midboot". Watched 4 cutscenes. Check your game MD5 matches redump.
I'm using the redump set but will confirm the MD5. However, 4 cutscenes is not long enough for the problem to manifest. Let it loop for 30-60 minutes and see if it hangs. I should add that I have K1V2 manually enabled via file in the game directory but got the same result using Midboot
Last edited by mario64 on September 1st, 2019, 9:37 am, edited 1 time in total.

User avatar
Takehaniyasubiko
/// CYBDYN SYSTEMS ELITE ///
/// CYBDYN SYSTEMS ELITE ///
Posts: 918
Joined: March 13th, 2018, 5:04 am

Re: Lunar: Silver Star Story doesn't work in K1v3

Post by Takehaniyasubiko » September 1st, 2019, 9:31 am

mario64 wrote:
September 1st, 2019, 9:23 am
I'm using the redump set but will confirm the MD5. However, 4 cutscenes is not long enough for the problem to manifest. Let it loop for 30-60 minutes and see if it hangs
You should check this with the real CD as well because Working Designs really sucked at game programming. It's possibly a bug in the game. Not saying it is because I don't have the original CD. Somebody should check this, though.

mario64
Member
Member
Posts: 18
Joined: August 4th, 2019, 9:23 am

Re: Lunar: Silver Star Story doesn't work in K1v3

Post by mario64 » September 1st, 2019, 9:37 am

Takehaniyasubiko wrote:
September 1st, 2019, 9:31 am
mario64 wrote:
September 1st, 2019, 9:23 am
I'm using the redump set but will confirm the MD5. However, 4 cutscenes is not long enough for the problem to manifest. Let it loop for 30-60 minutes and see if it hangs
You should check this with the real CD as well because Working Designs really sucked at game programming. It's possibly a bug in the game. Not saying it is because I don't have the original CD. Somebody should check this, though.
Good point. I will do that. I have the game

mario64
Member
Member
Posts: 18
Joined: August 4th, 2019, 9:23 am

Re: Lunar: Silver Star Story doesn't work in K1v3

Post by mario64 » September 1st, 2019, 10:56 am

mario64 wrote:
September 1st, 2019, 9:37 am
Takehaniyasubiko wrote:
September 1st, 2019, 9:31 am
mario64 wrote:
September 1st, 2019, 9:23 am
I'm using the redump set but will confirm the MD5. However, 4 cutscenes is not long enough for the problem to manifest. Let it loop for 30-60 minutes and see if it hangs
You should check this with the real CD as well because Working Designs really sucked at game programming. It's possibly a bug in the game. Not saying it is because I don't have the original CD. Somebody should check this, though.
Good point. I will do that. I have the game
Detached the PSIO then loaded up the CD. It ran for 72 minutes with no issues whatsoever

fernan1234
Lives in the Cybdyn Systems Server
Lives in the Cybdyn Systems Server
Posts: 179
Joined: June 4th, 2018, 8:23 am

Re: Lunar: Silver Star Story doesn't work in K1v3

Post by fernan1234 » September 1st, 2019, 11:19 am

Yeah the game is not the problem. Hopefully the devs will have a chance to let this loop for 30-60 min until it crashes and catch the bug as it happens.

User avatar
Takehaniyasubiko
/// CYBDYN SYSTEMS ELITE ///
/// CYBDYN SYSTEMS ELITE ///
Posts: 918
Joined: March 13th, 2018, 5:04 am

Re: Lunar: Silver Star Story doesn't work in K1v3

Post by Takehaniyasubiko » September 1st, 2019, 11:21 am

mario64 wrote:
September 1st, 2019, 10:56 am
Detached the PSIO then loaded up the CD. It ran for 72 minutes with no issues whatsoever
Thanks for checking this. Now we know it's a PSIO error and maybe it will be helpful during debugging since it seems that after an extensive time of loading the same data over and over again, there's some error with PSIO reading.

User avatar
Matt
Cybdyn Systems - Admin
Cybdyn Systems - Admin
Posts: 2455
Joined: December 31st, 2012, 5:37 pm
I am a: Systems Designer
PlayStation Model: H2000/5502
Location: Australia
Contact:

Re: Lunar: Silver Star Story doesn't work in K1v3

Post by Matt » September 1st, 2019, 12:28 pm

So just leave the game running at this place for an hour?

Image
Attachments
54236-Lunar_Silver_Star_Story_Complete_(J)-3.png
(491.73 KiB) Not downloaded yet

mario64
Member
Member
Posts: 18
Joined: August 4th, 2019, 9:23 am

Re: Lunar: Silver Star Story doesn't work in K1v3

Post by mario64 » September 1st, 2019, 1:14 pm

No just boot up the game and let it run on its own. It will loop between the Start screen and the opening video over and over.

User avatar
Matt
Cybdyn Systems - Admin
Cybdyn Systems - Admin
Posts: 2455
Joined: December 31st, 2012, 5:37 pm
I am a: Systems Designer
PlayStation Model: H2000/5502
Location: Australia
Contact:

Re: Lunar: Silver Star Story doesn't work in K1v3

Post by Matt » September 1st, 2019, 1:29 pm

mario64 wrote:
September 1st, 2019, 1:14 pm
No just boot up the game and let it run on its own. It will loop between the Start screen and the opening video over and over.
Ah, no problem. I will do that and monitor it :)

SavitarSvit
Active at Cybdyn Systems
Active at Cybdyn Systems
Posts: 52
Joined: May 14th, 2017, 3:09 am

Re: Lunar: Silver Star Story doesn't work in K1v3

Post by SavitarSvit » September 1st, 2019, 6:16 pm

I wait 13 loops on K1V2, total - 20 minutes. The game is stable. I don`t see a reason to wait 1 hour. And why do you need to wait for exactly an hour, not 24 hours? 24 hours are even more reliable than 1 hour.

If there was a problem, then it can be tracked. It is necessary that someone else confirms the presence of an error in the game. In the meantime, this does not happen, most likely a problem with your SD card.

User avatar
Matt
Cybdyn Systems - Admin
Cybdyn Systems - Admin
Posts: 2455
Joined: December 31st, 2012, 5:37 pm
I am a: Systems Designer
PlayStation Model: H2000/5502
Location: Australia
Contact:

Re: Lunar: Silver Star Story doesn't work in K1v3

Post by Matt » September 1st, 2019, 6:24 pm

Confirmed. I left it running with Midboot mode for over an hour and it didn't freeze.

User avatar
krisk77
/// CYBDYN SYSTEMS ELITE ///
/// CYBDYN SYSTEMS ELITE ///
Posts: 367
Joined: December 9th, 2015, 1:37 pm

Re: Lunar: Silver Star Story doesn't work in K1v3

Post by krisk77 » September 1st, 2019, 6:55 pm

My guess it's the SD card. I say this because it could have a problem with seek times/reads after so many tries depending on a particular title, especially if data is constantly streamed back and forth.

When I tested GDEMU some years back (PSIO is completely different I know but can use this as an example) I found that certain brands of SD cards would fail on Crazy Taxi, if it was left on the demo loop after 30 minutes or so (these were genuine cards btw) yet would appear perfectly fine with other games.

It could be possible that this could be similair here and that the SD card in question is not up to it's job. Just a guess but thought i'd mention it.
NTSC JP 5000 PU-8/PSIO Switchboard
NTSC JP 7000 PU-20/Mayumi 4 chip + PSIO Switchboard

PAL 7502 PU-22/Mayumi 4 Chip + PSIO Switchboard

User avatar
Takehaniyasubiko
/// CYBDYN SYSTEMS ELITE ///
/// CYBDYN SYSTEMS ELITE ///
Posts: 918
Joined: March 13th, 2018, 5:04 am

Re: Lunar: Silver Star Story doesn't work in K1v3

Post by Takehaniyasubiko » September 1st, 2019, 7:30 pm

It's beneficial to check all problems with games, even if it's something obscure like running the intro/main menu loop for an hour. You can never tell how somebody will use their games. For example, somebody might use the intro as an exhibit on some convention. Or maybe they just like like it that much - the reason doesn't matter.

If this is an SD card problem, it would be great to check what card it is and put this info into PSIO's FAQ because this will clearly affect other games if it's really and SD card issue.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest