Resident Evil 3 ntsc dialogue sound disappears reappears with long loading

Software title information and feedback tested by customers
Forum rules
Before posting, make sure you have tried all the EXTDSP settings available found in the 'Options' in the Menu System! Also be sure to check JIRA if your game is currently not working and is already being worked on.
User avatar
Takehaniyasubiko
/// CYBDYN SYSTEMS ELITE ///
/// CYBDYN SYSTEMS ELITE ///
Posts: 895
Joined: March 13th, 2018, 5:04 am

Re: Resident Evil 3 ntsc dialogue sound disappears reappears with long loading

Post by Takehaniyasubiko » April 24th, 2019, 12:33 am

Matt wrote:
April 23rd, 2019, 4:11 pm
The logic in the cartridge doesn't work like that however. It's not possible. We need to fix the problems and perfect the firmware in each update.
Amen to that.
Yuri wrote:
April 23rd, 2019, 7:11 pm
it can be fixed)
just it takes longer time to figure out why it happens)
in most cases non-standard lib is used by the same game company
That's great. Take your time, Yuri. I'm not a programmer, but I know how this stuff can drive somebody crazy because fixing one thing most often breaks something elese. The exact same thing happens with Open PS2 Loader, always because of some non-standard game code. Many console developers used very, very weird code, ignoring many of the official guidelines.

fernan1234
Lives in the Cybdyn Systems Server
Lives in the Cybdyn Systems Server
Posts: 177
Joined: June 4th, 2018, 8:23 am

Re: Resident Evil 3 ntsc dialogue sound disappears reappears with long loading

Post by fernan1234 » April 24th, 2019, 4:32 am

Matt wrote:
April 23rd, 2019, 4:11 pm
The logic in the cartridge doesn't work like that however. It's not possible. We need to fix the problems and perfect the firmware in each update.
I see. Now I understand that downgrading would not be feasible. Well I do have confidence that you guys will eventually take it all the way to virtually complete compatibility. Thanks for the info.

User avatar
Matt
Cybdyn Systems - Admin
Cybdyn Systems - Admin
Posts: 2443
Joined: December 31st, 2012, 5:37 pm
I am a: Systems Designer
PlayStation Model: H2000/5502
Location: Australia
Contact:

Re: Resident Evil 3 ntsc dialogue sound disappears reappears with long loading

Post by Matt » April 24th, 2019, 5:02 am

Takehaniyasubiko wrote:
April 24th, 2019, 12:33 am
... many console developers used very, very weird code, ignoring many of the official guidelines.
*cough* Psygnosis.

thhiago2202
Just Joined
Just Joined
Posts: 1
Joined: August 22nd, 2019, 5:09 am

Re: Resident Evil 3 ntsc dialogue sound disappears reappears with long loading

Post by thhiago2202 » August 22nd, 2019, 6:12 am

Hello, Im having this random long loading problem in resident evil 2 and 3 too.
In my case i have only noticed the dialogue problem in Resident Evil 3 and in just one of my SD card, in the others it appears to work fine, but i didn't do long tests on Resident Evil 3 I just played the first 10 minutes of the game.
But the long loading problem I have tried others SD cards and none have solve the problem. I have noticed this happens once or twice every five minutes of playing and it happens in Resident Evil 2 and 3 I didn't test the Resident Evil 1.

About the SD clusters size, what do you recommend for a better compatibility? I always put in the biggest possible.

Sorry if I wrote something wrong. English is not my native language.

Thank you very much.

User avatar
NRGDEAD
/// CYBDYN SYSTEMS ELITE ///
/// CYBDYN SYSTEMS ELITE ///
Posts: 528
Joined: September 22nd, 2017, 3:10 am
I am a: Noob
PlayStation Model: SCPH-1002

Re: Resident Evil 3 ntsc dialogue sound disappears reappears with long loading

Post by NRGDEAD » August 22nd, 2019, 7:21 am

thhiago2202 wrote:
August 22nd, 2019, 6:12 am
About the SD clusters size, what do you recommend for a better compatibility?
256 KiB regular, if something doesn't work it's worth trying 1024 KiB.
Cue2cu2 - Python script for creating CU2 sheets via command line on Linux/Mac/Windows.

PSIO wallpaper template in PSD format.

User avatar
Takehaniyasubiko
/// CYBDYN SYSTEMS ELITE ///
/// CYBDYN SYSTEMS ELITE ///
Posts: 895
Joined: March 13th, 2018, 5:04 am

Re: Resident Evil 3 ntsc dialogue sound disappears reappears with long loading

Post by Takehaniyasubiko » September 4th, 2019, 8:58 am

Resident Evil 2 & 3 tested on V2.6.7.

Elongated load times, taking roughly 10-15 seconds each time, happen very often when opening doors and picking up items.

Audio playback is broken in both games. In RE3, the scene with Brad Vickers in Bar Jack had about half of the dialogue missing. In RE2, the scene with Marvin Branagh had a very long pause before Leon said "But!" (he should say it after two seconds, for comparison, check this video - https://youtu.be/kYmeNHhwQd4?t=763).

User avatar
Matt
Cybdyn Systems - Admin
Cybdyn Systems - Admin
Posts: 2443
Joined: December 31st, 2012, 5:37 pm
I am a: Systems Designer
PlayStation Model: H2000/5502
Location: Australia
Contact:

Re: Resident Evil 3 ntsc dialogue sound disappears reappears with long loading

Post by Matt » September 11th, 2019, 3:03 am

I tested it, and it seems to be okay now. You'll have to test it properly for us when the new firmware is released :)

User avatar
Takehaniyasubiko
/// CYBDYN SYSTEMS ELITE ///
/// CYBDYN SYSTEMS ELITE ///
Posts: 895
Joined: March 13th, 2018, 5:04 am

Re: Resident Evil 3 ntsc dialogue sound disappears reappears with long loading

Post by Takehaniyasubiko » September 11th, 2019, 3:04 am

Matt wrote:
September 11th, 2019, 3:03 am
I tested it, and it seems to be okay now. You'll have to test it properly for us when the new firmware is released :)
I think it will work now because the timing for the voice files relies heavily on the pause command, but better to test than not to test, that's for sure.

Andrey39rume
Member
Member
Posts: 34
Joined: September 1st, 2019, 1:28 am

Re: Resident Evil 3 ntsc dialogue sound disappears reappears with long loading

Post by Andrey39rume » September 12th, 2019, 8:48 am

Firmware 2.6.8, on k1v4 and midboot there is no sound in the opening video (Jill sits on the bed). About video with helicopters (after video with Jill) at me everything is excellent, but I have national version in Russian (video took from version for personal computer).

User avatar
Takehaniyasubiko
/// CYBDYN SYSTEMS ELITE ///
/// CYBDYN SYSTEMS ELITE ///
Posts: 895
Joined: March 13th, 2018, 5:04 am

Re: Resident Evil 3 ntsc dialogue sound disappears reappears with long loading

Post by Takehaniyasubiko » September 12th, 2019, 8:51 am

Andrey39rume wrote:
September 12th, 2019, 8:48 am
About video with helicopters (after video with Jill) at me everything is excellent, but I have national version in Russian (video took from version for personal computer).
Unfortunately, it's not excellent. The black screens after opening doors are too long and audio disappears at various points in the game, including the ending.

Andrey39rume
Member
Member
Posts: 34
Joined: September 1st, 2019, 1:28 am

Re: Resident Evil 3 ntsc dialogue sound disappears reappears with long loading

Post by Andrey39rume » September 12th, 2019, 9:04 am

Takehaniyasubiko wrote:
September 12th, 2019, 8:51 am
Andrey39rume wrote:
September 12th, 2019, 8:48 am
About video with helicopters (after video with Jill) at me everything is excellent, but I have national version in Russian (video took from version for personal computer).
Unfortunately, it's not excellent. The black screens after opening doors are too long and audio disappears at various points in the game, including the ending.
Okay, but I think Matt 's pretty close. Now it is the slowdown in loads between scenes in games that is noticeable. Not critical, but this effect is present

User avatar
Takehaniyasubiko
/// CYBDYN SYSTEMS ELITE ///
/// CYBDYN SYSTEMS ELITE ///
Posts: 895
Joined: March 13th, 2018, 5:04 am

Re: Resident Evil 3 ntsc dialogue sound disappears reappears with long loading

Post by Takehaniyasubiko » September 12th, 2019, 9:05 am

Andrey39rume wrote:
September 12th, 2019, 9:04 am
Okay, but I think Matt 's pretty close. Now it is the slowdown in loads between scenes in games that is noticeable. Not critical, but this effect is present
Yes, he is pretty close now. However, this is still critical because audio disappears at certain parts and the in-game cutscenes are not synced to sound effects.

Andrey39rume
Member
Member
Posts: 34
Joined: September 1st, 2019, 1:28 am

Re: Resident Evil 3 ntsc dialogue sound disappears reappears with long loading

Post by Andrey39rume » September 12th, 2019, 9:23 am

Resident evil 2 works well, only with midboot mode, but in the process of playing when the door closes still black screen for three to four seconds.

User avatar
Takehaniyasubiko
/// CYBDYN SYSTEMS ELITE ///
/// CYBDYN SYSTEMS ELITE ///
Posts: 895
Joined: March 13th, 2018, 5:04 am

Re: Resident Evil 3 ntsc dialogue sound disappears reappears with long loading

Post by Takehaniyasubiko » September 12th, 2019, 9:28 am

Both RE2 and RE3 have too long pauses after closing doors.

In RE3, there are also obvious problems with missing audio in some videos and no synchronization between in-game cutscenes and sound effects.

We're closer to fixing these game, but they are defo not fixed yet.

User avatar
Matt
Cybdyn Systems - Admin
Cybdyn Systems - Admin
Posts: 2443
Joined: December 31st, 2012, 5:37 pm
I am a: Systems Designer
PlayStation Model: H2000/5502
Location: Australia
Contact:

Re: Resident Evil 3 ntsc dialogue sound disappears reappears with long loading

Post by Matt » September 12th, 2019, 1:51 pm

I'll adjust the seek timing and that should then fix it.

SavitarSvit
Active at Cybdyn Systems
Active at Cybdyn Systems
Posts: 52
Joined: May 14th, 2017, 3:09 am

Re: Resident Evil 3 ntsc dialogue sound disappears reappears with long loading

Post by SavitarSvit » September 12th, 2019, 6:45 pm

No sound in cutscene NTSC U version.
Link to the desired segment.: https://youtu.be/HanEBMeas28?t=40

User avatar
Matt
Cybdyn Systems - Admin
Cybdyn Systems - Admin
Posts: 2443
Joined: December 31st, 2012, 5:37 pm
I am a: Systems Designer
PlayStation Model: H2000/5502
Location: Australia
Contact:

Re: Resident Evil 3 ntsc dialogue sound disappears reappears with long loading

Post by Matt » September 12th, 2019, 8:52 pm

No sound in that clip would be an EXTDSP selection issue. Try another mode.

User avatar
Takehaniyasubiko
/// CYBDYN SYSTEMS ELITE ///
/// CYBDYN SYSTEMS ELITE ///
Posts: 895
Joined: March 13th, 2018, 5:04 am

Re: Resident Evil 3 ntsc dialogue sound disappears reappears with long loading

Post by Takehaniyasubiko » September 12th, 2019, 9:34 pm

Matt wrote:
September 12th, 2019, 8:52 pm
No sound in that clip would be an EXTDSP selection issue. Try another mode.
It's not an EXTDSP selection issue. Both I and krisk77 checked this yesterday and we both confirmed none of the EXTDSP modes fixes this. This is a timing issue. krisk77 even checked the ending video and it also doesn't have any audio, so this will happen at various points in the game.

Another bug introduced in ARM 2.6.4 - in-game scenes are not synced with sound effects anymore. Can be seen right after the game starts: when Jill jumps through the burning doors, the scene is not synced well with the explosion sound effect.

Don't shoot the messenger. We don't create these bugs. We only report them out of our goodwill and care for the product.

User avatar
krisk77
/// CYBDYN SYSTEMS ELITE ///
/// CYBDYN SYSTEMS ELITE ///
Posts: 367
Joined: December 9th, 2015, 1:37 pm

Re: Resident Evil 3 ntsc dialogue sound disappears reappears with long loading

Post by krisk77 » September 13th, 2019, 12:11 am

Definitley not a EXDSP issue Matt on the US/NTSC version I tested all and they make no difference as this only occurred after the timings were adjusted in the ARM.
NTSC JP 5000 PU-8/PSIO Switchboard
NTSC JP 7000 PU-20/Mayumi 4 chip + PSIO Switchboard

PAL 7502 PU-22/Mayumi 4 Chip + PSIO Switchboard

User avatar
Takehaniyasubiko
/// CYBDYN SYSTEMS ELITE ///
/// CYBDYN SYSTEMS ELITE ///
Posts: 895
Joined: March 13th, 2018, 5:04 am

Re: Resident Evil 3 ntsc dialogue sound disappears reappears with long loading

Post by Takehaniyasubiko » September 13th, 2019, 1:50 am

It makes perfect sense, though. The load times are too long now, so PS1 skips the playback of some tracks. Before, the load times were too fast, so PS1 was skipping playback of some other tracks. This is confirming what I've heard from the creator of Mednafen: you must get the timing perfectly synced with a real PS1 CD-ROM (a healthy one reading a retail disc) or else the majority of games won't play properly.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest