Official PSIO News and Development Thread

Official Development, Research, Bug Fixes and Progress directly from Cybdyn Systems
Forum rules
This section is for development news, research, bug fixes, progress, changes and information in regards to PSIO directly posted from Cybdyn Systems. Do not post any questions here relating to your order as they will be deleted. Instead, please go back and create a new post in the "Help and Support" forum. Thanks.
Stupid Dufus
Just Joined
Just Joined
Posts: 3
Joined: December 6th, 2018, 2:27 am

Re: Official PSIO News and Development Thread

Post by Stupid Dufus » December 6th, 2018, 2:34 am

No errors. No confirmation if it worked or didn't.

Stupid Dufus
Just Joined
Just Joined
Posts: 3
Joined: December 6th, 2018, 2:27 am

Re: Official PSIO News and Development Thread

Post by Stupid Dufus » December 6th, 2018, 2:39 am

OK, now I'm getting a notification that my login isn't correct, despite checking my info.
Put in the e-mail I ordered with
Put in the 12-digit s/n from the back of the PSIO
Put in the 4-digit order number

Virtual_Davey
Just Joined
Just Joined
Posts: 6
Joined: December 6th, 2018, 1:50 am

Re: Official PSIO News and Development Thread

Post by Virtual_Davey » December 6th, 2018, 2:41 am

"Incorrect Email Address, Order ID or Serial Number. Please refresh the page and try again".
No downloads counter.

jacksprat1990
Member
Member
Posts: 10
Joined: January 14th, 2016, 8:49 am

Re: Official PSIO News and Development Thread

Post by jacksprat1990 » December 6th, 2018, 2:50 am

Virtual_Davey wrote:
December 6th, 2018, 2:41 am
"Incorrect Email Address, Order ID or Serial Number. Please refresh the page and try again".
No downloads counter.
Same.

User avatar
Matt
Cybdyn Systems - Admin
Cybdyn Systems - Admin
Posts: 2136
Joined: December 31st, 2012, 5:37 pm
I am a: Systems Designer
PlayStation Model: H2000/5502
Location: Australia
Contact:

Re: Official PSIO News and Development Thread

Post by Matt » December 6th, 2018, 3:40 am

Okay, should all be working decently fine now :)

Virtual_Davey
Just Joined
Just Joined
Posts: 6
Joined: December 6th, 2018, 1:50 am

Re: Official PSIO News and Development Thread

Post by Virtual_Davey » December 6th, 2018, 3:53 am

Now I'm getting "Incorrect Serial Number. Please refresh the page and try again".

User avatar
Matt
Cybdyn Systems - Admin
Cybdyn Systems - Admin
Posts: 2136
Joined: December 31st, 2012, 5:37 pm
I am a: Systems Designer
PlayStation Model: H2000/5502
Location: Australia
Contact:

Re: Official PSIO News and Development Thread

Post by Matt » December 6th, 2018, 4:02 am

Private message me your order ID please and the serial number so I can manually check it for you to make sure the code isn't giving you a bad error.

User avatar
zredgemz
Lives in the Cybdyn Systems Server
Lives in the Cybdyn Systems Server
Posts: 193
Joined: November 24th, 2015, 9:48 am
PlayStation Model: SCPH-5501

Re: Official PSIO News and Development Thread

Post by zredgemz » December 6th, 2018, 5:31 am

Working now. Thanks.

fernan1234
Seriously Active at Cybdyn Systems
Seriously Active at Cybdyn Systems
Posts: 102
Joined: June 4th, 2018, 8:23 am

Re: Official PSIO News and Development Thread

Post by fernan1234 » December 6th, 2018, 5:31 am

Really excited about the XA audio fix! That was the key factor that was keeping this from being the ultimate solution to play most of the PSX library! Thank you!

I just got my PSIO cart from December preorders in the mail yesterday and have not set it up. Should I go ahead and boot it and set it up on my PSX first, and then update the FPGA, ARM, and MENU after? Or should I place all those files on the SD card and follow the update instructions on the Systems Manual before anything else?

User avatar
fille1976
Seriously Active at Cybdyn Systems
Seriously Active at Cybdyn Systems
Posts: 87
Joined: November 15th, 2015, 9:19 pm

Re: Official PSIO News and Development Thread

Post by fille1976 » December 6th, 2018, 6:30 am

Thx Matt for the new update.
I just updated and all went fine.
Keep up the good work,xevious is working again,great job.
Gona test in the next up coming days.

User avatar
krisk77
/// CYBDYN SYSTEMS ELITE ///
/// CYBDYN SYSTEMS ELITE ///
Posts: 255
Joined: December 9th, 2015, 1:37 pm

Re: Official PSIO News and Development Thread

Post by krisk77 » December 6th, 2018, 8:24 am

Matt, just thought I'd mention that the download page for firmwares and manuals is not a secure connection i.e HTTPS. With having to enter personal info like Email address, password and serial numbers of the product, it's not ideal to have it not encrypted.
NTSC JP 5000 PU-8/PSIO Switchboard
NTSC JP 7000 PU-20/Mayumi 4 chip + PSIO Switchboard

PAL 7502 PU-22/Mayumi 4 Chip + PSIO Switchboard

User avatar
KarlG
Member
Member
Posts: 26
Joined: September 5th, 2018, 7:39 am
PlayStation Model: SCPH-1002
Location: United Kingdom

Re: Official PSIO News and Development Thread

Post by KarlG » December 6th, 2018, 10:53 am

Just done some further testing and Spyro 3 NTSC V1.1 (ReDump Verified) (Unpatched) works using audio mode K1V2. Tried 3 times and it went past the Bianca animation fine. :dance I haven't played much more than about 10 mins or so as my time is limited at the moment, just though I would let you know.

I read in the update notes that using the restart playstation option should go back to the bios so you can manage memory cards. On mine it just hangs on PSIO (No Loading Bar) when you select the option. Before the update it would reset the console and reload the PSIO system menu. I really want to be able to get into the memory card management screen without having to remove the PSIO and risk bending any of the pins. Would there be a way to add a button combination such as Start + Select or Start,Select,L1,R1,L2,R2 to boot back to bios?

User avatar
Matt
Cybdyn Systems - Admin
Cybdyn Systems - Admin
Posts: 2136
Joined: December 31st, 2012, 5:37 pm
I am a: Systems Designer
PlayStation Model: H2000/5502
Location: Australia
Contact:

Re: Official PSIO News and Development Thread

Post by Matt » December 6th, 2018, 1:26 pm

fernan1234 wrote:
December 6th, 2018, 5:31 am
Really excited about the XA audio fix! That was the key factor that was keeping this from being the ultimate solution to play most of the PSX library! Thank you!

I just got my PSIO cart from December preorders in the mail yesterday and have not set it up. Should I go ahead and boot it and set it up on my PSX first, and then update the FPGA, ARM, and MENU after? Or should I place all those files on the SD card and follow the update instructions on the Systems Manual before anything else?
Place all the latest update files on the SD Card and power on. It'll be fine :)

krisk77 wrote:
December 6th, 2018, 8:24 am
Matt, just thought I'd mention that the download page for firmwares and manuals is not a secure connection i.e HTTPS. With having to enter personal info like Email address, password and serial numbers of the product, it's not ideal to have it not encrypted.
Thanks, I will work on adding HTTPS.

KarlG wrote:
December 6th, 2018, 10:53 am
I read in the update notes that using the restart playstation option should go back to the bios so you can manage memory cards. On mine it just hangs on PSIO (No Loading Bar) when you select the option. Before the update it would reset the console and reload the PSIO system menu. I really want to be able to get into the memory card management screen without having to remove the PSIO and risk bending any of the pins. Would there be a way to add a button combination such as Start + Select or Start,Select,L1,R1,L2,R2 to boot back to bios?
Ah, yes, that's a bug that we need to fix. I will get that sorted in the next update :)

User avatar
Tgames
Active at Cybdyn Systems
Active at Cybdyn Systems
Posts: 46
Joined: July 10th, 2016, 12:59 pm

Re: Official PSIO News and Development Thread

Post by Tgames » December 8th, 2018, 2:09 am

Just updated to the lastest firmware.

Nice about XA audio Fix !

Atlantis The Lost Tales (PAL) now don't have any red screen with the new firmware but just a black screen on boot.
Last edited by Tgames on December 8th, 2018, 2:32 am, edited 1 time in total.

User avatar
Matt
Cybdyn Systems - Admin
Cybdyn Systems - Admin
Posts: 2136
Joined: December 31st, 2012, 5:37 pm
I am a: Systems Designer
PlayStation Model: H2000/5502
Location: Australia
Contact:

Re: Official PSIO News and Development Thread

Post by Matt » December 8th, 2018, 2:20 am

Tgames wrote:
December 8th, 2018, 2:09 am
Just update to the lastest firmware.

Nice about XA audio Fix !

Atlantis The Lost Tales (PAL) now don't have any red screen with the new firmware but just a black screen on boot.
Thanks! Ah, I'll check that out again soon :)

User avatar
Tgames
Active at Cybdyn Systems
Active at Cybdyn Systems
Posts: 46
Joined: July 10th, 2016, 12:59 pm

Re: Official PSIO News and Development Thread

Post by Tgames » December 8th, 2018, 2:43 am

Matt wrote:
December 8th, 2018, 2:20 am
Tgames wrote:
December 8th, 2018, 2:09 am
Just update to the lastest firmware.

Nice about XA audio Fix !

Atlantis The Lost Tales (PAL) now don't have any red screen with the new firmware but just a black screen on boot.
Thanks! Ah, I'll check that out again soon :)
Thanks Matt :). For the moment Atlantis The Lost Tales (Secret d'un monde oublié in french) is the only game from Cryo Interactive who doesn't works on PSIO.
All others games (Egypt, Egypt 2, China, Aztec) works fine.

Egypt I : Works Fine
Egypt II: The Heliopolis Prophecy : Works Fine
China: The Forbidden City : Works Fine
Aztec: The Curse in the Heart of the City of Gold : Works Fine
Louvre : Works Fine
Last edited by Tgames on December 8th, 2018, 3:17 am, edited 1 time in total.

User avatar
Tgames
Active at Cybdyn Systems
Active at Cybdyn Systems
Posts: 46
Joined: July 10th, 2016, 12:59 pm

Re: Official PSIO News and Development Thread

Post by Tgames » December 8th, 2018, 3:11 am

@Matt

Versailles 1685 (PAL) (Complot à la Cour du Roi Soleil in french) doesn't work

Like Atlantis The Lost Tales, a red screen with a error and debugging message :

Probably Cryo had badly coded Atlantis The Lost Tales and Versailles and they use something PSIO use also.

Versailles and Atlantis uses the same engine so maybe it's the explanation.

Image

Maybe if you just fix Atlantis it will fix also Versailles...

User avatar
Simplebit
Just Joined
Just Joined
Posts: 8
Joined: January 28th, 2017, 12:45 am

Re: Official PSIO News and Development Thread

Post by Simplebit » December 9th, 2018, 2:48 am

Matt wrote:
December 4th, 2018, 11:12 pm
Okay. New FPGA Firmware available. This will fix the problem where it freezes on the "Initialising" screen :)

Thanks to everyone who helped work with me to solve the problem.
Remember now that all future updates will only require the Menu System ;)

Code: Select all

  [STY3] 02/12/2018
	- Improved data reading (fixes "Wipeout").
hi matt, mine still freezes on the "Initializing" screen with new FPGA Firmware, my PSIO ver is 9510-2213

User avatar
Matt
Cybdyn Systems - Admin
Cybdyn Systems - Admin
Posts: 2136
Joined: December 31st, 2012, 5:37 pm
I am a: Systems Designer
PlayStation Model: H2000/5502
Location: Australia
Contact:

Re: Official PSIO News and Development Thread

Post by Matt » December 9th, 2018, 3:30 am

Did you also update the ARM Firmware?

scrappysphinx
Member
Member
Posts: 22
Joined: October 10th, 2018, 2:34 am
I am a: Gamer
PlayStation Model: SCPH-5552
Location: United Kingdom

Re: Official PSIO News and Development Thread

Post by scrappysphinx » December 9th, 2018, 3:38 am

Hi, i have logged in and downloaded the update but cannot extract the zip files. Tried the latest Winrar and 7Zip but get "unknown format or damaged" when trying to extract either the arm,menu or firmware zips and 7zip gives an error saying unable to open as zip file. Do i need to change the extension or something?

Ok, multiple downloads with chrome and all fail to extract, downloaded with microsoft edge and i can open it with winrar but its requesting a password to extract? Where do i find the password?

Nevermind, figured out the extraction password wasmy PSIO Serial Number


Scratch that. Menu system opened and extracted fine, arm firmware and and fpga firmware both still fail to open, giving me an error about them being "unknown format or damaged"

Finally got everything downloaded (had to use edge for the menu and internet explorer for the fpga and arm firmware and PSIO has been updated. Still having issues with Soul Blade (PAL) though. Game loads and audio is now fixed but game freezes on starting a battle showing the characters selected screen. Game works fine from disc and in epsxe on my pc though
Last edited by scrappysphinx on December 9th, 2018, 4:16 am, edited 1 time in total.

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests