Page 1 of 2

Issue with Menu System V2.6.17 Update

Posted: September 9th, 2020, 7:54 pm
by EmteCoke
Just downloaded the newest firmware but my PSIO won't update gets stuck at the System Loading Screen and the PSIO light is solid orange try using other SD cards no good same issues :(

Re: Issue with Menu System V2.6.17 Update

Posted: September 9th, 2020, 9:11 pm
by NRGDEAD
Does the old version still boot? Does it show the "no SD card" error when you boot without the card?

Re: Issue with Menu System V2.6.17 Update

Posted: September 9th, 2020, 9:36 pm
by Matt
Hmm. That's strange. No idea why it's doing that. Have you tried holding START + SELECT on power on?

Re: Issue with Menu System V2.6.17 Update

Posted: September 9th, 2020, 10:01 pm
by Takehaniyasubiko
Make sure your download file isn't faulty. It sometimes happens.

V2.6.17 updated normally for me.

Re: Issue with Menu System V2.6.17 Update

Posted: September 9th, 2020, 11:39 pm
by sk8er000
Same problem here, I've tried to update from 2.6.12 to 2.6.17 (I downloaded some weeks ago 2.6.14 but never installed).

Tried different SDs but it always stuck at the "loading system" screen.
If I put back 2.6.12 menu.sys it boots like before.

Anyone has solved this issue?

I downloaded the fw once but I'm scared to download it again since I've read that someone ended up with his original psio recognised as clone

Re: Issue with Menu System V2.6.17 Update

Posted: September 10th, 2020, 2:46 am
by EmteCoke
NRGDEAD wrote:
September 9th, 2020, 9:11 pm
Does the old version still boot? Does it show the "no SD card" error when you boot without the card?
Yes Menu System V2.6.16 still boots

Re: Issue with Menu System V2.6.17 Update

Posted: September 10th, 2020, 2:59 am
by EmteCoke
Matt wrote:
September 9th, 2020, 9:36 pm
Hmm. That's strange. No idea why it's doing that. Have you tried holding START + SELECT on power on?
Did that and it rested the PSIO to defeult but still can't update get stuck at the PSIo please wait screen

Re: Issue with Menu System V2.6.17 Update

Posted: September 10th, 2020, 3:08 am
by fille1976
Mine too,seriously,what is this testing ????????????????????????????????
The 1 that tested bugs ect...,they pestered him away from here,luckily its not bricked,i'm running out of patience with this situation.
@Take,so i dl it twice,still same happen,how many times i'm supposed to dl the firmware,5-10-20 times?
This is bullshit,happy i will get my x-station cause i'm tired of this.

Re: Issue with Menu System V2.6.17 Update

Posted: September 10th, 2020, 3:10 am
by HOL2001
Same problem here!
Reverting to V2.6.16 makes the system work again.

Re: Issue with Menu System V2.6.17 Update

Posted: September 10th, 2020, 3:14 am
by Takehaniyasubiko
fille1976 wrote:
September 10th, 2020, 3:08 am
@Take,so i dl it twice,still same happen,how many times i'm supposed to dl the firmware,5-10-20 times?
Worked for me on the first try. :shrug

Re: Issue with Menu System V2.6.17 Update

Posted: September 10th, 2020, 3:16 am
by dlmvii
As another data point, this is happening to me as well when upgrading to 2.6.17 . I haven't encountered this before

Re: Issue with Menu System V2.6.17 Update

Posted: September 10th, 2020, 3:17 am
by HOL2001
Downloading the firmware was no problem at all. (as usual)
But I did also DL by using the alternate link.
Both versions let the PSX freeze.

Re: Issue with Menu System V2.6.17 Update

Posted: September 10th, 2020, 3:18 am
by Omnislash
Received my PSIO and updated it directly to V2.6.16 , and updating to V2.6.17 worked on the first try also.
But so many people having issues to update is a bit worrying

Re: Issue with Menu System V2.6.17 Update

Posted: September 10th, 2020, 3:30 am
by dlmvii
dlmvii wrote:
September 10th, 2020, 3:16 am
As another data point, this is happening to me as well when upgrading to 2.6.17 . I haven't encountered this before
I tried holding select + start to reset the system as Matt suggested above, and it is working fine now after it reset the psio and seemed to reinstall everything.

Re: Issue with Menu System V2.6.17 Update

Posted: September 10th, 2020, 3:31 am
by Takehaniyasubiko
HOL2001 wrote:
September 10th, 2020, 3:17 am
But I did also DL by using the alternate link.
Maybe that's the problem?

I use the first link. The download will start in about 1 minute, so just wait after clicking it.

Also, try resetting PSIO with START+SELECT on the initialization screen.

Re: Issue with Menu System V2.6.17 Update

Posted: September 10th, 2020, 3:35 am
by fille1976
So this means suddenly everbody is dl there firmwares corrupted,who believes that.

Re: Issue with Menu System V2.6.17 Update

Posted: September 10th, 2020, 3:37 am
by Takehaniyasubiko
fille1976 wrote:
September 10th, 2020, 3:35 am
So this means suddenly everbody is dl there firmwares corrupted,who believes that.
A lot of people already updated with no issues, so it's not "everybody".

Re: Issue with Menu System V2.6.17 Update

Posted: September 10th, 2020, 3:40 am
by fille1976
@take,start-select solved the problem,but something is wrong,i never have to do that before.

Re: Issue with Menu System V2.6.17 Update

Posted: September 10th, 2020, 3:44 am
by Takehaniyasubiko
fille1976 wrote:
September 10th, 2020, 3:40 am
@take,start-select solved the problem,but something is wrong,i never have to do that before.
Did you update from 2.6.16?

When I updated from 2.6.16, it did it automatically with no issues.

Re: Issue with Menu System V2.6.17 Update

Posted: September 10th, 2020, 3:45 am
by fille1976
So i checked something else,background music is off,if i want to set it on,console freeze.
Just tried alien resurrection,no sound,what the hell is this,really professional.
C'mon matt,fix this shit seriously,this isn't funny anymore,and for fuck sake,TEST THE FUCKING SHIT BEFORE RELEASING PLEASE.