PSIO Switch Board Install Check

Feel free to go ahead and ask for Help and Support or check out what's already been answered from other customers
Forum rules
This section is for asking about help in regards to your PSIO Cartridge. Do not post any questions here relating to your order. Instead, please open a support ticket in our Service Desk. Thanks.
Post Reply
TrevorFlaps
Just Joined
Just Joined
Posts: 3
Joined: June 14th, 2020, 10:31 pm

PSIO Switch Board Install Check

Post by TrevorFlaps » June 14th, 2020, 10:42 pm

Hi all. I installed the PSIO switch board yesterday/today but I cannot boot past the PSIO logo (nothing else on screen).

From reading the forum this is most likely due to a bad switch board install, but I'm stuck on exactly what may be wrong, so was hoping someone could take a look at some pictures of the board.

I know this is a messy install, I'm sorry about that.

The PS1 boots to BIOS fine with the PSIO unplugged. It also boots a retail game with no problems. I tried my flashcard with Unirom installed and that boots with no issues, and boots backups.

So the PS1 has not lost any functionality, the PSIO just isn't booting. Could it be that some traces are not cut properly? My multimeter indicates they are cut.

Thank you in advance for any input.

(Files were too large to upload here, so they are on Google Photos - https://photos.app.goo.gl/dtcVSzHQZCAY6GHc7)

User avatar
fille1976
Lives in the Cybdyn Systems Server
Lives in the Cybdyn Systems Server
Posts: 125
Joined: November 15th, 2015, 9:19 pm

Re: PSIO Switch Board Install Check

Post by fille1976 » June 14th, 2020, 10:59 pm

Keep your wires short,why make them so long????
Measure everything with multimeter.
Did you get psio on the psx booting screen?
If not,probably a wire or some wires not correctly soldered.

User avatar
James-F
/// CYBDYN SYSTEMS ELITE ///
/// CYBDYN SYSTEMS ELITE ///
Posts: 836
Joined: August 11th, 2019, 11:01 pm

Re: PSIO Switch Board Install Check

Post by James-F » June 14th, 2020, 11:02 pm

.
Last edited by James-F on June 30th, 2020, 10:15 pm, edited 1 time in total.
SCPH-7000 (x2), SCPH-7501, SCPH-101, SCPH-102

User avatar
AMG13
/// CYBDYN SYSTEMS ELITE ///
/// CYBDYN SYSTEMS ELITE ///
Posts: 344
Joined: October 22nd, 2019, 8:14 am
PlayStation Model: SCPH-7002

Re: PSIO Switch Board Install Check

Post by AMG13 » June 14th, 2020, 11:18 pm

In the photo in red, I show how the wire should lie in order to avoid contact with the GND. otherwise PSIO will not work properly, this is a very common user error.
Image

User avatar
Matt
Cybdyn Systems - Admin
Cybdyn Systems - Admin
Posts: 3906
Joined: December 31st, 2012, 5:37 pm
I am a: Systems Designer
PlayStation Model: H2700/5502
Location: Australia
Contact:

Re: PSIO Switch Board Install Check

Post by Matt » June 14th, 2020, 11:56 pm

Horrible Switch Board install. The trace next to EN (enable) looks damaged too.

TrevorFlaps
Just Joined
Just Joined
Posts: 3
Joined: June 14th, 2020, 10:31 pm

Re: PSIO Switch Board Install Check

Post by TrevorFlaps » June 15th, 2020, 2:30 am

Thank you to everyone for their comments. I understand it is a particularly bad install, but this was one of my first times soldering, so... :shrug I did acknowledge that.

Anyway, the biggest THANK YOU goes out to AMG13 and for his image. I took care to avoid the ground pads in the centre of the board but didn't even think about the grounds at the side. Your picture helped a lot.

I moved the wires - the PSIO is now working! :D

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests