anyone having trouble downloading menu system file?

Feel free to go ahead and ask for Help and Support or check out what's already been answered from other customers
noz1380
Just Joined
Just Joined
Posts: 8
Joined: December 28th, 2018, 7:44 pm

Re: anyone having trouble downloading menu system file?

Post by noz1380 » December 31st, 2018, 10:51 pm

Matt wrote:
December 31st, 2018, 1:55 am
Connection reset... hmm. I honestly have no idea what could be causing that. I ain't using Linux with Apache, I'm using Windows Server with IIS but I don't think it's an IIS issue.

If you're competent with Linux, maybe you can dump the HTTP headers and show me them?

EG: This is what I am getting with CURL:

Code: Select all

HTTP/1.1 200 OK
Cache-Control: must-revalidate, post-check=0, pre-check=0,private
Pragma: public
Content-Length: 67818467
Content-Type: application/zip
Expires: 0
Server: Microsoft-IIS/8.0
X-Powered-By: PHP/5.5.19
Content-Disposition: attachment; filename="MENU265_XXXXXXXXXXXX.ZIP";
Content-Transfer-Encoding: binary
X-Powered-By: ASP.NET
Date: Sun, 30 Dec 2018 15:23:22 GMT
Sorry, I only just manage with Linux to serve my requirements, I'm not a user.

If it helps I downloaded the PU-22 data (72mb ish) perfectly fine. Just the menu system thats the problem.

User avatar
aha2940
Member
Member
Posts: 11
Joined: December 30th, 2018, 11:52 am
I am a: IT consultant
PlayStation Model: SCPH-7501

Re: anyone having trouble downloading menu system file?

Post by aha2940 » January 1st, 2019, 11:40 am

I tried and got this:

Code: Select all

[user01@linux ~]$ curl -v "https://ps-io.com/firmwares/download.php?s=HTI0NjE6OTM4OA==&r=81d8ce6336cbca75feb944e108df586b1&v=MDU6NzE2MDAfNTQ"
*   Trying 223.27.29.141...
* TCP_NODELAY set
* Connected to ps-io.com (223.27.29.141) port 443 (#0)
* ALPN, offering h2
* ALPN, offering http/1.1
* successfully set certificate verify locations:
*   CAfile: /etc/pki/tls/certs/ca-bundle.crt
  CApath: none
* TLSv1.3 (OUT), TLS handshake, Client hello (1):
* TLSv1.3 (IN), TLS handshake, Server hello (2):
* TLSv1.2 (IN), TLS handshake, Certificate (11):
* TLSv1.2 (IN), TLS handshake, Server finished (14):
* TLSv1.2 (OUT), TLS handshake, Client key exchange (16):
* TLSv1.2 (OUT), TLS change cipher, Change cipher spec (1):
* TLSv1.2 (OUT), TLS handshake, Finished (20):
* TLSv1.2 (IN), TLS handshake, Finished (20):
* SSL connection using TLSv1.2 / AES128-SHA256
* ALPN, server did not agree to a protocol
* Server certificate:
*  subject: OU=Domain Control Validated; OU=PositiveSSL; CN=ps-io.com
*  start date: Feb 27 00:00:00 2017 GMT
*  expire date: Feb 27 23:59:59 2020 GMT
*  subjectAltName: host "ps-io.com" matched cert's "ps-io.com"
*  issuer: C=GB; ST=Greater Manchester; L=Salford; O=COMODO CA Limited; CN=COMODO RSA Domain Validation Secure Server CA
*  SSL certificate verify ok.
> GET /firmwares/download.php?s=HTI0NjE6OTM4OA==&r=81d8ce6336cbca75feb944e108df586b1&v=MDU6NzE2MDAfNTQ HTTP/1.1
> Host: ps-io.com
> User-Agent: curl/7.61.1
> Accept: */*
> 
< HTTP/1.1 403 Not Found
< Content-Type: text/html
< Server: Microsoft-IIS/8.0
< X-Powered-By: PHP/5.5.19
< X-Powered-By: ASP.NET
< Date: Tue, 01 Jan 2019 00:37:45 GMT
< Content-Length: 0
< 
* Connection #0 to host ps-io.com left intact
[user01@linux ~]$

User avatar
Matt
Cybdyn Systems - Admin
Cybdyn Systems - Admin
Posts: 1655
Joined: December 31st, 2012, 5:37 pm
I am a: Systems Designer
Skype: psio94
Location: Australia
Contact:

Re: anyone having trouble downloading menu system file?

Post by Matt » January 2nd, 2019, 4:23 pm

Looks like it can't find the file. That means the URL you entered was wrong. Are you sure it was correct?

User avatar
aha2940
Member
Member
Posts: 11
Joined: December 30th, 2018, 11:52 am
I am a: IT consultant
PlayStation Model: SCPH-7501

Re: anyone having trouble downloading menu system file?

Post by aha2940 » January 3rd, 2019, 1:09 am

Matt wrote:
January 2nd, 2019, 4:23 pm
Looks like it can't find the file. That means the URL you entered was wrong. Are you sure it was correct?
Oh, I could get the files fine, got them some time ago, no issues. I was just testing the URL that was posted in this thread some days ago, I thought that could be useful, but it seems it's not :)

User avatar
Matt
Cybdyn Systems - Admin
Cybdyn Systems - Admin
Posts: 1655
Joined: December 31st, 2012, 5:37 pm
I am a: Systems Designer
Skype: psio94
Location: Australia
Contact:

Re: anyone having trouble downloading menu system file?

Post by Matt » January 3rd, 2019, 6:30 pm

That's weird. 'Content-Length' should not be 0.

simonc
Just Joined
Just Joined
Posts: 2
Joined: January 5th, 2019, 10:16 am

Re: anyone having trouble downloading menu system file?

Post by simonc » January 5th, 2019, 10:18 am

Cannot download the menu file, tried on multiple browsers and smartphone. The worst part is that you cannot download it somewhere else because it is tied to your hardware.

Please fix

seanami
Just Joined
Just Joined
Posts: 4
Joined: December 13th, 2018, 6:34 am

Re: anyone having trouble downloading menu system file?

Post by seanami » January 5th, 2019, 4:07 pm

I can't download it either, been almost a month and cant get someone to switch my second hand PSIO over to me, they stopped replying to emails

simonc
Just Joined
Just Joined
Posts: 2
Joined: January 5th, 2019, 10:16 am

Re: anyone having trouble downloading menu system file?

Post by simonc » January 5th, 2019, 7:51 pm

Tried again this morning and for some reasons it worked perfectly :shrug

noz1380
Just Joined
Just Joined
Posts: 8
Joined: December 28th, 2018, 7:44 pm

Re: anyone having trouble downloading menu system file?

Post by noz1380 » January 9th, 2019, 6:10 am

Still not downloading.

Matt do you have a time frame on fixing this issue??

I'm getting pretty fed up of this.........Very poor customer service.

nexilar
Just Joined
Just Joined
Posts: 2
Joined: January 9th, 2019, 6:30 am

Re: anyone having trouble downloading menu system file?

Post by nexilar » January 9th, 2019, 7:01 am

any update on this? I also have the issue. it stops exactly at 19.81M every time

does your PHP script streams the file in "chunks"?

Code: Select all

$file = fopen($filePath,"rb");
while(!feof($file))
{
	print(@fread($file, 1024*8));
	ob_flush();
	flush();
}
another solution could be to use fpassthru

Code: Select all

$file = fopen($filePath,"rb");
ob_end_clean(); // large files might not work without this line
@fpassthru($file);
also in order to allow the download to continue from where stopped with wget's -c option you need to send the ranges headers in the response. Right now it just starts all over again.

User avatar
Matt
Cybdyn Systems - Admin
Cybdyn Systems - Admin
Posts: 1655
Joined: December 31st, 2012, 5:37 pm
I am a: Systems Designer
Skype: psio94
Location: Australia
Contact:

Re: anyone having trouble downloading menu system file?

Post by Matt » January 9th, 2019, 2:00 pm

seanami wrote:
January 5th, 2019, 4:07 pm
I can't download it either, been almost a month and cant get someone to switch my second hand PSIO over to me, they stopped replying to emails
We have over 200 emails to get through. I'm slowly working my way through the holiday and new years emails that are piled up.

nexilar wrote:
January 9th, 2019, 7:01 am
any update on this? I also have the issue. it stops exactly at 19.81M every time. does your PHP script streams the file in "chunks"?
No, I transfer it directly

Code: Select all

header('Pragma: public');
header('Expires: 0');
header('Cache-Control: must-revalidate, post-check=0, pre-check=0');
header('Cache-Control: private', false); // required for certain browsers
header('Content-Type: application/zip');
header('Content-Disposition: attachment; filename="'. basename($download) . '_' . $url_serial . '.ZIP";');
header('Content-Transfer-Encoding: binary');
header('Content-Length: ' . filesize(__DIR__.'/'.basename($download) . '_' . $url_serial . '.ZIP'));

readfile(__DIR__.'/'.basename($download . '_' . $url_serial . '.ZIP'));
I was thinking another way is to use FTP instead. Might give that a shot.

nexilar
Just Joined
Just Joined
Posts: 2
Joined: January 9th, 2019, 6:30 am

Re: anyone having trouble downloading menu system file?

Post by nexilar » January 10th, 2019, 12:52 am

Hey Matt,

Idk your server, php.ini, apache/nginx, etc configurations. but to me it seems like readfile might be using all the memory allowed for your PHP processes.

readfile will load all the file into PHP memory and it might produce some issues, that's why iterating over the file, reading parts of it and flushing once in a while to empty the buffer, might prevent it.

BTW, I was able to download the file this morning (About 8am UTC+1). Maybe your server has less load at that time, just a guess.

Good luck solving the issue!

User avatar
Matt
Cybdyn Systems - Admin
Cybdyn Systems - Admin
Posts: 1655
Joined: December 31st, 2012, 5:37 pm
I am a: Systems Designer
Skype: psio94
Location: Australia
Contact:

Re: anyone having trouble downloading menu system file?

Post by Matt » January 10th, 2019, 3:33 am

Ah, that makes sense. What I have done now is switched back to HTML downloading protocols, so it should be okay now. If not, we will switch over to the PHP code which writes it in chunks in that while loop example. Thanks :)

noz1380
Just Joined
Just Joined
Posts: 8
Joined: December 28th, 2018, 7:44 pm

Re: anyone having trouble downloading menu system file?

Post by noz1380 » January 13th, 2019, 7:50 am

Matt, thank you for sorting this. Very much appreciated.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest